Microsoft Outlook Visibility Issues
Incident Report for A Corp Computers
Resolved
Microsoft have confirmed that this issue is now resolved.
If you continue to experience issues, please ensure you restart the Microsoft Outlook application. This should ensure the fix takes effect.
Following this, please contact our support team if you continue to have problems viewing emails.
Posted May 13, 2021 - 07:50 AEST
Identified
Microsoft are investigating an issue with email message visibility in Outlook. This issue is causing emails to not download and display correctly within the Microsoft Outlook client installed on PCs and Macs.

Outlook on the web appears to be unaffected and can be used as a workaround during this outage. To access, login with you credentials at https://outlook.office.com. Or you can use your mobile device which is also unaffected at this stage.

More details can be found under EX255650 in the admin center.
Posted May 12, 2021 - 07:42 AEST
This incident affected: Microsoft Cloud.